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1 Introduction 
What is BonSAI_2014? 
BonSAI_2014 is a software application that can be used to help with assigning Subject 
Achievement Indicators (SAIs) and checking the reasonableness of SAI distributions. It imports 
and exports data to and from the QCAA’s Student Data Capture System (SDCS).  

‘BonSAI’ means ‘good’ SAI. 

What are SAIs? 
SAIs are numerical indicators assigned at the end of Year 12 to students in a large subject group 
(14 or more OP-eligible students) within a school to indicate the rank order and relative 
differences in achievement when they are compared with each other. SAIs provide input data for, 
and are the first stage in, calculating Overall Positions (OPs). The highest achieving student in a 
group receives an SAI of 400, the lowest receives an SAI of 200, regardless of levels of 
achievement (LOAs). Teachers decide and assign SAIs. For more information, see the QCAA’s 
SAIs and BonSAI webpage: www.qcaa.qld.edu.au/4903.html. 

Do I need data from my school before I can use BonSAI_2014? 
No. The installation of BonSAI_2014 contains data for ‘Example School’ (school code ‘0’) with 
which you can interact. You can download class lists with LOAs and Forms R6 to go with this 
data and simulate various operations in BonSAI_2014. 

For more information about using the Example School data see Section 7. 

How can BonSAI_2014 be used to assign SAIs? 
Subject groups are imported into BonSAI_2014 using files from SDCS. BonSAI_2014 allows 
users to place and move students’ names on a screen showing a 200–400 scale. Tools such as 
‘anchor students’ facilitate this process. BonSAI_2014 assigns SAIs based on the physical 
position of the students on the scale. After checking for reasonableness, files can be exported 
back to SDCS. BonSAI_2014 cannot allocate differences between students. When assigning 
SAIs, teachers need to use evidence in folios to make decisions. BonSAI_2014 is simply a tool to 
help facilitate this process. 

See Section 5 of this guide for details about using BonSAI_2014 to assign SAIs. 

How can BonSAI_2014 be used to check the reasonableness of SAIs? 
SAI distributions should have some resemblance to the placement of students on Forms R6. 
This is because decisions are being made about the same group of students, using the same 
information (completed assessment). BonSAI_2014 uses a basic ‘average points per rung’ 
calculation, i.e. number of rungs covered (inclusive) divided by number of points used. 
To calculate average points per rung: 

• count the number of rungs covered inclusively, e.g. a student is on SA2, the next student is on 
SA6 — this is 5 rungs 

• determine the number of points used in this part of the distribution (e.g. the student on SA2 
has an SAI of 220, the student on SA6 has an SAI of 240 — this is 20 SAI points) 
In BonSAI_2014, where there are multiple SAIs on a rung, the ‘outermost’ SAI on that 
rung is used to determine the range of SAI points 

http://www.qcaa.qld.edu.au/4903.html
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• divide the number of points used, by the number of rungs covered, e.g. 20 points, 5 rungs = 
average 4 points per rung. 

This calculation can then be used to compare different points in the distribution. BonSAI_2014 
produces tables and graphs based on this calculation that provide a quick and easy way to check 
the reasonableness of SAI distributions. 

There are three things that should be checked to ensure SAI distributions are reasonable: 

1. Odd gaps, e.g. students on adjacent rungs would be expected to have closer SAIs than 
students several rungs apart 

2. Increasing amounts of difference between students from the bottom of the distribution to 
the top, i.e. smaller ratio in VLA or LA compared with HA or VHA. This is because of the 
increasing complexity and amounts of work required as LOAs increase. Distributions should 
not be linear (see below) 

3. Double the difference. When comparing average points per rung used in different parts of the 
distribution, the difference will never be double, e.g. if points per rung in LA is 3.2, points per 
rung should never be 6.4 or greater anywhere else in the distribution. Similarly, though, when 
comparing different parts of a distribution it would only be expected that close to ‘double the 
difference’ is reached when most of the Form R6 is covered. 

Section 6 provides information about tools for checking the reasonableness of SAI distributions. 

What is a linear distribution? 
A linear distribution occurs when there are exactly the same or a similar number of ‘points per 
rung’ used across the entire distribution, and often students on the same rung receive the 
same SAI. It is unlikely that a distribution would naturally occur this way and it is not acceptable 
because it will unfairly advantage some students and therefore disadvantage others. 
BonSAI_2014 creates an initial linear distribution that is to be used as a starting point only. 

What are pair-wise comparisons? 
A suggested method to help assign SAIs is to make a series of pair-wise comparisons between 
three students. For example, when comparing students A, B and C, A is compared with B and B 
compared with C, to determine whether B is more like A or more like C. B is then moved along 
the 200–400 scale accordingly. The next comparison would take place between students B, C 
and D. B is compared with C and C compared with D to determine whether C is more like B or 
more like D. C is then moved along the scale accordingly. Repeat this process as many times as 
necessary. 

Can I check SAIs using BonSAI_2014 if I have not used it to assign 
them? 
Yes. You can enter SAIs either into SDCS and import the data, or manually enter SAIs into 
BonSAI_2014. You can then use the tools in BonSAI_2014 to check the reasonableness of 
your decisions. 
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2 Installing BonSAI_2014 
Single user 
Download the install file from QCAA’s SAIs and BonSAI webpage: 
www.qcaa.qld.edu.au/4903.html. 

Your web browser should allow you to save the file to a location you select. 

Navigate to the directory in which you saved the file and open it. You might like to close other 
programs before you do this. The install program will open. Follow the prompts. The installer will 
ask you for a directory in which to install the program. Make sure this is a directory where you can 
read (access/open) and write (save files/install programs). A shortcut will be created on your 
desktop. 

Multiple users 
Follow the procedure above, installing BonSAI_2014 to a network drive. Ensure that all users 
have read/write access to the folder where BonSAI_2014 is installed. To maintain data integrity, 
only one user should access a particular subject at any one time. 

http://www.qcaa.qld.edu.au/4903.html
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3 BonSAI_2014 and SDCS 
BonSAI_2014 is designed to import your school’s SDCS files and for these files to be exported 
from BonSAI_2014 and back into SDCS when you have finished. This eliminates the need for 
manual entry of SAIs into SDCS. Only certain people have authority to use SDCS, and they will 
need to use the information below to provide the files for others to work with. 

Getting data from SDCS 
All data accessed in BonSAI_2014 is obtained via the use of export files from your school’s 
SDCS. There are two types of export that can be used: 

• single subject export 

• data submission/exchange disk. 

Single subject export 
A single subject export from SDCS will place the LOAs and SAIs (as they appear in SDCS) of all 
OP-eligible students into a file named ‘subj####.out’ (where #### is the subject number code). 
To export this data from SDCS: 

1. Start SDCS, select the File menu and then select SAI Export. 

2. Using the directory browser, select the location where you would like the file to be saved. 

3. In the Subject Selection area, select the One Authority Subject radio button. 

4. Using the dropdown arrow on the right of the Subject Selection area, choose the subject 
you wish to export and click OK. 

A file called ‘subj##.out’ should now be in the specified location. 

Data submission/exchange disk export 
A data submission export file from SDCS contains the LOAs, SAIs and OP-eligibility statuses 
of all students in a specified file named ‘exch###.v#’ (where ### is the school code and # is a 
number between 1 and 5 specific to which data exchange you are up to). To export this data 
from SDCS: 

1. Start SDCS, select the File menu and then select Create Exchange Disk. 

2. Read warnings that may appear and check the messages as they apply to you. 

3. Type the location to save the file in the ‘Destination’ box. 

4. Specify which exchange disk version you wish to export in the Exchange Disk area 
(we advise against using the Year 11 Enrolment Disk). 

5. Click Process. Check that no significant problems have been encountered on the windows 
that subsequently appear. 

A file containing the relevant information should now be in the specified location. 
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Importing data into BonSAI_2014 
Once you have your export file from SDCS it is easy to import into BonSAI_2014. Before 
proceeding, close any open subject editing windows (if they are open you will be warned and 
asked if you are willing to let the program close them).  

To import data into BonSAI_2014: 

1. Start BonSAI_2014, entering your school name or number. 

2. Click on the  icon on the task bar or select Import file from the File menu. 

3. Using the file browser select the file you wish to import into BonSAI_2014. 

4. Click Open (a warning will appear if any subject editing windows are open). 

A ‘Please wait’ message box will appear. When this closes the import is complete. 

Exporting from BonSAI_2014 and getting data back into SDCS 
Once you have completed editing a subject’s SAI distribution in BonSAI_2014, you can export the 
data from BonSAI_2014 back into SDCS. This will bring the SAI and LOA changes you have 
made in BonSAI_2014 across into SDCS. 

In BonSAI_2014: 
1. Select the subject for which you wish to export data. 

2. Click on the  icon on the task bar or select Export subject from the File menu. 

3. Using the file dialog that appears, select the location where you wish to save the export file. 
This dialog will also inform you of the name for the new file. 

4. Click OK. 

In SDCS: 
1. Select Import from the File menu. 

2. Use the Format drop-down menu in the top left to select SAIASSG and click Select. 

3. Use the Browse button to select Open a file. 

4. Select the file you exported from BonSAI_2014 and click Open, then click Process. 

The changes made in BonSAI_2014 will now be integrated into the SDCS database. 
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4 Getting started with BonSAI_2014 
This user guide refers to sample data for an example school, given the school number ‘0’. 
To import your own school’s data, type in your school’s name or choose your school’s QCAA 
ID number. You can work with the ‘Example School’ data to familiarise yourself with using 
BonSAI_2014. 

1. When you open BonSAI_2014, you will have a similar screen display to this. 

 
 
2. When you click on OK, you will see a screen similar to this. 

 

This pane will  
be for your own 
school and you 
will need to import 
data from SDCS. 

Select school 
number or school 
0 to begin using 
BonSAI_2014.2. 
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The BonSAI_2014 screen 
 
 

 
 

 

Click this tab  
to create an 
electronic  
Form R6. 

Student enrolment 
pane — data comes 
from SDCS: Visa 
status, OP eligibility, 
LOA. 
 
Form R6 rung 
placements are 
entered into 
BonSAI_2014.2 by 
teachers. 

Graphs to 
check SAI 
distributions. 

Maximise or 
minimise any of 
the panes. 

Zoom in or out 
when panes are 
maximised. 

Subject list 
(large groups 
only) 

Editing pane —  
drag and drop student 
names to place them 
on the 200–400 scale. 
 

Subject 
information 
tables 
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5 Assigning SAIs 
1. Import a subject file (see Section 3) and open the subject by clicking on it. Information 

imported will include LOAs if these have been entered into SDCS. 

2. Enter students’ Form R6 rung placements (and LOAs if required). Sort students into rank 
order by clicking Rung. 

 
 

3. Click on the Quick Layout button to get an initial distribution in the editing pane — this will 
be a linear distribution and warning messages will appear. The linear distribution is a starting 
point only to place students in rank order on the screen (see Section 1). 

Quick 
Layout 
button 

Enter rung 
information 
then click on 
Rung to sort 
into rank order. 
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4. Select some anchor students in the column beside student names — these will then appear 
in red in the editing pane. Drag and drop anchor students’ names along the 200–400 scale to 
represent gaps between students. When you drag anchor students, surrounding students will 
automatically move with them. A useful method is to make a series of pair-wise comparisons 
(see Section 1) between anchor students. 

 
 

 
 

5. When you are satisfied with the placement of anchor students, make necessary adjustments 
to the placement of other students. Consider comparing students on the same rung and the 
fact that the initial ‘linear’ distribution will have placed students in the ‘middle’ of the rung. 
As you drag and drop student names, their SAIs will automatically change. 

6. Save the distribution you have created by clicking File then Save Subject. Your distribution 
will be saved in the BonSAI_2014 database and will be available to open later. Save before 
you export your distribution (see Section 3). 

Click on this  
column to select 
anchor students. 
Using anchor 
students is optional 
but makes student 
comparisons easier. 

SAIs appear 
automatically. 

Anchor students 
appear to the 
left in red. 

Click this button to 
shrink or expand  
non-anchor students. 
Shrinking is helpful for 
very large groups. 

Information now 
appears in the 
graphs and tables. 
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6 Checking the reasonableness of SAI 
distributions 
Read Section 1 to see what should be checked.  

BonSAI_2014 contains several tools for checking SAI distributions. These are the same checks 
QCAA staff use when schools submit SAI distributions. The various tools should be used together 
to ensure that the SAI distribution is reasonable. Sometimes one tool will show something that 
another will not. You can have the graphs and tables open as you are dragging students in the 
editing pane, or maximise them for easier viewing. 

Rungs to SAIs graph 
This graph is useful to quickly show possible anomalies when comparing SAIs to Form R6 rung 
placement. A ‘reasonable’ distribution will show the red line generally curving underneath the 
‘linear’ marker. The line need not be smooth, but any unusually large peaks or dips, or places 
where the red line crosses the black line, need investigating. 

 
  

Black line shows 
where a linear 
distribution would  
lie (very unlikely  
for distributions  
to naturally fall  
this way). 
 

Red line shows 
SAIs plotted against 
R6 rung placement. 
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Information tables 
 

 

Interpreting the Ratio information table 
In general, the average points per rung (see page 4) should increase through the LOAs, 
i.e. be lowest in the lower LOAs and highest in the highest LOA (see Section 1). If they do not, 
the distribution should be checked and reassessed. 

Asterisks 

When an asterisk (*) appears in the table, the average points per rung has been calculated over 
only 2 rungs (because there are adjacent students on the Form R6, e.g. HA10 and VHA1). It is 
acceptable for numbers with an asterisk to be small, because students on adjacent rungs may 
be similar to each other. However, if these numbers are large, the reasonableness of the gap 
between adjacent students should be checked.  

In BonSAI_2014, where there are multiple SAIs on a rung, the average points per rung are 
calculated using the ‘outermost’ SAIs on that rung.  

Note: An asterisk will not appear for an adjacent rung calculation if the ratio is the largest in the 
table.  

Ratio information shows ‘points per rung’ 
calculation and indicates maximum ratio 
multiplicity. A ‘reasonable’ multiplier will be 
less than 2, as there should never be more 
than ‘double the difference’ (see Section 1). 

Missing data alerts you to a mismatch 
between the Form R6 rungs and SAIs 
assigned. Ensure you also check against  
the hard copy Form R6. 

Subject cohort information allows you to 
check you have the correct total number of 
students and correct number of OP-eligible 
students entered 
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SAIs over LOAs graph (The ‘R’ graph) 
This graph shows individual SAIs in levels of achievement. It is very helpful for checking 
reasonable gaps between students against the Form R6. 

 

Bars shows 
individual students’ 
SAIs in levels of 
achievement. 

Numbers at the 
bottom show 
‘average points 
per rung’ within 
and between  
each LOA. 
 

Scale shows 
number of 
students. 

SAIs  
200–400 
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7 Using Example School data 
The Example School data allows users to see and interact with three types of simulated subject 
cohorts for ‘Example School’: 

• fully completed distributions 

• distributions that have had SAIs already assigned 

• distributions that have not yet had SAIs assigned. 

To work with Example School data, choose school number ‘0’ when you open BonSAI_2014. 
Download and print class lists with LOAs and sample Forms R6 to go with the data from the 
QCAA’s SAIs and BonSAI webpage: www.qcaa.qld.edu.au/4903.html. 

Looking at fully completed SAI distributions 
Subjects 37, 38, 40 and 41 are fully completed SAI distributions. Use these to familiarise yourself 
with the tools in BonSAI_2014. Use the tables and the graphs to determine if the SAI distributions 
are reasonable. Compare the completed distributions with the information on class lists and 
Forms R6. Manipulate students’ positions in the editing pane and observe changes to SAIs, 
graphs and tables. 

Looking at distributions that have had SAIs already assigned 
Subjects 1, 21 and 42 include SAIs that have already been assigned and imported into 
BonSAI_2014. To interact fully with these distributions, you will need to enter the Form R6 
rungs into the student enrolment pane. Get this information from class lists you download. 

  
  

Complete this 
column using 
the information  
on class lists. 

Observe 
graphs/tables 
as R6 data  
is entered. 
 

http://www.qcaa.qld.edu.au/4903.html
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Looking at distributions that have not yet had SAIs assigned 
Subjects 62, 68, 72 and 80 include class lists and LOAs only. You can enter the Form R6 rungs 
for these groups from the class lists you download. You can then simulate allocating SAIs for 
these subject groups. 

Remember that BonSAI_2014 does not make decisions about differences between students. 
Without folios of work for these students, you cannot make real decisions about differences. 
The exercise simply allows you to interact with the tools available in BonSAI_2014. 

  

1. Enter rung 
information,  
then click on 
‘Rung’ to sort 
into rank order. 

3. Use the Quick 
Layout button to 
create an initial 
distribution. 

 

2. Assign  
some anchor 
students. 

4. Drag and drop student 
names to place them  
on the 200–400 scale. 
Watch SAIs change as 
you do this. 
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8 Advanced tasks in BonSAI_2014 
Emptying the BonSAI_2014 database 
Subject distributions are stored in the BonSAI_2014 database. You can remove the entire 
database and start afresh. Individual subjects cannot be removed, and it is suggested you export 
all subjects in the database before removing it, in case they are required again. To empty the 
database: 

1. Navigate your file explorer to the place where you installed BonSAI_2014. 

2. Under this directory you will find a folder named ‘bonsai’ (note the lower case). 

3. Delete only this folder. 

The next time you start BonSAI_2014, the database will be empty, ready for new files to be 
imported. 

Exchanging data between BonSAI_2014 applications 
This may be required if teachers: 

• are working on distributions on multiple computers 

• are using earlier versions of the program 

• wish to give a distribution to another person to look at.  

The process uses the import and export features described in Section 3. 

In the first copy of BonSAI_2014: 
1. Select the subject for which you wish to export data. 

2. Click on the  icon on the task bar or select Export subject from the File menu. 

3. Using the file dialog that appears, select the location where you wish to save the export file. 
This dialog will also inform you of the name for the new file. 

4. Click OK. 

In the second copy of BonSAI_2014: 

1. Click on the  icon on the task bar or select Import file from the File menu. 

2. Using the file browser select the file you wish to import into BonSAI_2014. 

3. Click Open (you will get a warning if any subject editing windows are open). 

4. A ‘Please wait’ message box will appear. When this closes the import is complete. 

Creating CSV files 
You can create Excel files of student enrolment data (including SAIs) and Form R6 data. 

1. Select the subject for which you wish to create the CSV files. 

2. From the Information menu, select Save enrolments CSV file or Save R6 CSV file, 
depending on whether you want to save enrolment or Form R6 data. 

3. Using the file dialog that appears, select the location where you wish to save the file and 
click OK.  
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Changing a student’s OP eligibility 
1. Highlight the student by clicking on the student’s name in the enrolment list. 

2. From the Information menu, select Change OP eligibility of student. 

Saving graphs 
1. Maximise the graph (or tables) that you wish to save. 

2. From the Information menu, select Save graph. 

3. Using the file dialog that appears, select the location where you wish to save the file and 
click OK. 

Printing graphs 
1. Maximise the graph (or tables) that you wish to print. 

2. From the Information menu, select Print graph. 

Changing colour preferences 
You can change the default colours used in BonSAI_2014 to suit your preference. 

1. From the Help menu, select Preferences. 

2. Use the screen provided to select new colours to display each LOA, then click OK. 

3. To return to the default colours, select Preferences, then click Delete preferences. 
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